FeedBurner FeedSmith Cross-Site Request Forgery Vulnerability

Friday, 12 October 2007

Vendor: Google


David Kierznowski has reported a vulnerability in FeedBurner FeedSmith, which can be exploited by malicious people to conduct cross-site request forgery attacks.

The vulnerability is caused due to the application allowing users to perform certain actions via HTTP requests without performing any validity checks to verify the request. This can be exploited to change certain settings and e.g. hijack blog feeds.

The vulnerability is reported in version 2.2. Prior versions may also be affected.

Update to version 2.3.

Provided and/or discovered by:
David Kierznowski

Original Advisories:

Share this content:
Home | News | Articles | Advisories | Submit | Alerts | Links | What is XSS | About | Contact | Some Rights Reserved.